水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/The latest and greatest news from the Arch Linux distribution.en-usMon, 24 Feb 2020 15:56:33 +0000水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/the-future-of-the-arch-linux-project-leader/<p>Hello everyone,</p> <p>Some of you may know me from the days when I was much more involved in Arch, but most of you probably just know me as a name on the website. I’ve been with Arch for some time, taking the leadership of this beast over from Judd back in 2007. But, as these things often go, my involvement has slid down to minimal levels over time. It’s high time that changes.</p> <p>Arch Linux needs involved leadership to make hard decisions and direct the project where it needs to go. And I am not in a position to do this.</p> <p>In a team effort, the Arch Linux staff devised a new process for determining future leaders. From now on, leaders will be elected by the staff for a term length of two years. Details of this new process can be found <a href="http://wiki.zjn60qd.cn/index.php/DeveloperWiki:Project_Leader">here</a></p> <p>In the first official vote with Levente Polyak (anthraxx), Gaetan Bisson (vesath), Giancarlo Razzolini (grazzolini), and Sven-Hendrik Haase (svenstaro) as candidates, and through 58 verified votes, a winner was chosen:</p> <p><strong>Levente Polyak (anthraxx) will be taking over the reins of this ship. Congratulations!</strong></p> <p><em>Thanks for everything over all these years,<br /> Aaron Griffin (phrakture)</em></p>Aaron GriffinMon, 24 Feb 2020 15:56:28 +0000tag:zjn60qd.cn,2020-02-24:/news/the-future-of-the-arch-linux-project-leader/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/planet-arch-linux-migration/<p>The software behind planet.zjn60qd.cn was implemented in Python 2 and is no longer maintained upstream. This functionality has now been implemented in zjn60qd.cn's archweb backend which is actively maintained but offers a slightly different experience.</p> <p>The most notable changes are the offered feeds and the feed location. Archweb only offers an Atom feed which is located at <a href="http://zjn60qd.cn/feeds/planet">here</a>.</p>Jelle van der WaaSat, 22 Feb 2020 22:43:00 +0000tag:zjn60qd.cn,2020-02-22:/news/planet-arch-linux-migration/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/sshd-needs-restarting-after-upgrading-to-openssh-82p1/<p>After upgrading to openssh-8.2p1, the existing SSH daemon will be unable to accept new connections. (See <a href="http://bugs.zjn60qd.cn/task/65517">FS#65517</a>.) When upgrading remote hosts, please make sure to restart the SSH daemon using <code>systemctl restart sshd</code> right after running <code>pacman -Syu</code>. If you are upgrading to openssh-8.2p1-3 or higher, this restart will happen automatically.</p>Gaetan BissonMon, 17 Feb 2020 01:35:04 +0000tag:zjn60qd.cn,2020-02-17:/news/sshd-needs-restarting-after-upgrading-to-openssh-82p1/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/rsync-compatibility/<p>Our <code>rsync</code> package was shipped with bundled <code>zlib</code> to provide compatibility with the old-style <code>--compress</code> option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.</p> <p>So we decided to finally drop the bundled library and ship a package with system <code>zlib</code>. This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with <code>rsync 3.1.3-3</code>.</p>Christian HesseWed, 15 Jan 2020 20:14:43 +0000tag:zjn60qd.cn,2020-01-15:/news/rsync-compatibility/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/now-using-zstandard-instead-of-xz-for-package-compression/<p>As announced on the <a href="http://lists.zjn60qd.cn/pipermail/arch-dev-public/2019-December/029752.html">mailing list</a>, on Friday, Dec 27 2019, our package compression scheme has changed from xz (.pkg.tar.xz) to <a href="http://lists.zjn60qd.cn/pipermail/arch-dev-public/2019-December/029778.html">zstd (.pkg.tar.zst)</a>.</p> <p>zstd and xz trade blows in their compression ratio. Recompressing all packages to zstd with our options yields a total ~0.8% increase in package size on all of our packages combined, but the decompression time for all packages saw a ~1300% speedup.</p> <p>We already have more than 545 zstd-compressed packages in our repositories, and as packages get updated more will keep rolling in. We have not found any user-facing issues as of yet, so things appear to be working.</p> <p>As a packager, you will automatically start building .pkg.tar.zst packages if you are using the latest version of devtools (&gt;= 20191227).<br /> As an end-user no manual intervention is required, assuming that you have read and followed the news post <a href="http://zjn60qd.cn/news/required-update-to-recent-libarchive/">from late last year</a>.</p> <p>If you nevertheless haven't updated libarchive since 2018, all hope is not lost! Binary builds of pacman-static are available from Eli Schwartz' <a href="http://wiki.zjn60qd.cn/index.php/Unofficial_user_repositories#eschwartz">personal repository</a> (or direct link to <a href="http://pkgbuild.com/~eschwartz/repo/x86_64-extracted/">binary</a>), signed with their Trusted User keys, with which you can perform the update.</p>Robin BrodaSat, 04 Jan 2020 20:35:55 +0000tag:zjn60qd.cn,2020-01-04:/news/now-using-zstandard-instead-of-xz-for-package-compression/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/xorg-cleanup-requires-manual-intervention/<p>In the process of <a href="http://bugs.zjn60qd.cn/task/64892">Xorg cleanup</a> the update requires manual intervention when you hit this message:</p> <pre><code>:: installing xorgproto (2019.2-2) breaks dependency 'inputproto' required by lib32-libxi :: installing xorgproto (2019.2-2) breaks dependency 'dmxproto' required by libdmx :: installing xorgproto (2019.2-2) breaks dependency 'xf86dgaproto' required by libxxf86dga :: installing xorgproto (2019.2-2) breaks dependency 'xf86miscproto' required by libxxf86misc </code></pre> <p>when updating, use: <code>pacman -Rdd libdmx libxxf86dga libxxf86misc &amp;&amp; pacman -Syu</code> to perform the upgrade.</p>Andreas RadkeFri, 20 Dec 2019 13:37:40 +0000tag:zjn60qd.cn,2019-12-20:/news/xorg-cleanup-requires-manual-intervention/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/primus_vk13-1-update-requires-manual-intervention/<p>The primus_vk package prior to version 1.3-1 was missing some soname links. This has been fixed in 1.3-1 so the upgrade will need to overwrite the untracked soname links. If you get an error like:</p> <pre><code>primus_vk: /usr/lib/libnv_vulkan_wrapper.so.1 exists in filesystem primus_vk: /usr/lib/libprimus_vk.so.1 exists in filesystem </code></pre> <p>when updating, use:</p> <p><code>pacman -Syu --overwrite=/usr/lib/libnv_vulkan_wrapper.so.1,/usr/lib/libprimus_vk.so.1</code></p> <p>to perform the upgrade.</p>Giancarlo RazzoliniMon, 25 Nov 2019 13:03:45 +0000tag:zjn60qd.cn,2019-11-25:/news/primus_vk13-1-update-requires-manual-intervention/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/new-kernel-packages-and-mkinitcpio-hooks/<p>All our official kernels: linux, linux-lts, linux-zen and linux-hardened, do not install the actual kernel to /boot anymore.</p> <p>The installation is done by mkinitcpio hooks and scripts, as well as removals. There is no need for any manual intervention.</p> <p>The intention is to make the kernel packages more self-contained, as well as making the boot process more flexible, while also keeping it backwards compatible.</p> <p>As of now, only mkinitcpio has hooks for handling kernels installations and removals. We do not ship any for dracut yet, but it will have similar hooks in the near future.</p>Giancarlo RazzoliniSun, 10 Nov 2019 21:41:24 +0000tag:zjn60qd.cn,2019-11-10:/news/new-kernel-packages-and-mkinitcpio-hooks/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/clarification-regarding-recent-email-activity-on-the-arch-announce-list/<p>Today, one email was sent to the arch-announce mailing list that was able to circumvent the whitelisting checks that are done by the mailman software. This was not due to unauthorized access and no Arch Linux servers were compromised.</p> <p>We have implemented measures to make sure this does not happen again, by using mailman's poster password feature. We are also making sure, these simple whitelist checks are not used anywhere else.</p> <p>Edited to add: There was a second email that was also sent today, in order to make sure the poster password feature was working. That email <em>did not</em> circumvent any check and was intentionally sent.</p>Giancarlo RazzoliniFri, 25 Oct 2019 20:27:46 +0000tag:zjn60qd.cn,2019-10-25:/news/clarification-regarding-recent-email-activity-on-the-arch-announce-list/水果老虎机旧版Arch Linux: Recent news updates http://zjn60qd.cn/news/required-update-to-recent-libarchive/<p>The compression algorithm <code>zstd</code> brings faster compression and decompression, while maintaining a compression ratio comparable with <code>xz</code>. This will speed up package installation with <code>pacman</code>, without further drawbacks.</p> <p>The imminent release of <strong>pacman 5.2</strong> brings build tools with support for compressing packages with <code>zstd</code>. To install these packages you need <code>libarchive</code> with support for <code>zstd</code>, which entered the repositories in September 2018. In order for <code>zstd</code> compressed packages to be distributed, we require all users to have updated to at least <strong>libarchive 3.3.3-1</strong>. You have had a year, so we expect you already did update. Hurry up if you have not.</p> <p>If you use custom scripts make sure these do not rely on hardcoded file extensions. The <code>zstd</code> package file extension will be <code>.pkg.tar.zst</code>.</p>Christian HesseWed, 16 Oct 2019 12:43:54 +0000tag:zjn60qd.cn,2019-10-16:/news/required-update-to-recent-libarchive/